Mutt: Install

From FVue
(Redirected from Mutt)
Jump to: navigation, search

Procedures

Create new mailbox (MailDir) to move message to

  1. Create directory mkdir ~freddy/proj/contact/contacts/foo
  2. In mutt, save {s} and create new file {N}

Setting up Mail Transfer Agent (SuSE)

  • Start YaST. Choose {Network Services | Mail Transfer Agent}.

Journal

20051016

  • Running postfix programs on my SuSE machine are:
freddy@linux:~> ps -ef | grep postfix
root      6872     1  0 21:15 ?        00:00:00 /usr/lib/postfix/master
postfix   6887  6872  0 21:15 ?        00:00:00 qmgr -l -t fifo -u
postfix   8043  6872  0 21:44 ?        00:00:00 pickup -l -t fifo -u
  • Mail transfer can be configured easily using {Control Center|YaST2 modules|Network Services|Mail Transfer Agent}?

20051029

  +-----+     +-----+     +------------+     +-----+
  | MTA +-->--+ MDA +-->--+ Mail store +-->--+ MUA |
  +-----+     +-----+     +------------+     +-----+

  MTA = Mail Transport Agent
  MDA = Mail Dispatch Agent
  MUA = Mail User Agent
  ([1])
  • Aliased freddy for root mail in /etc/aliases

20051108

It is the fetchmail process which is responsible for retrieving my e-mail:

/usr/bin/fetchmail -d 600 -a -f /etc/fetchmailrc -L /var/log/fetchmail

Connecting to my providers mail server tells me I'm using the ESMTP protocol:

freddy@linux:~> telnet mail.tip.nl 25
Trying 123.123.123.123...
Connected to mail.tip.nl.
Escape character is '^]'.
220 smtp5.tip.nl ESMTP Postfix

20051113

Fetchmail is delivering my e-mail to my unix-account (i.e. the file ~/mbox), accessible with mail (nail). How can I get it into mutt? Solution: specify in .muttrc: set spoolfile='/var/spool/mail/freddy'

There is a commented setting #home_mailbox = Maildir/ in my /etc/postfix/main.cf

E-mail info page with nice dataflow diagram

20051114

Added color index red default ~P to my .muttrc to get black letters on white background.

Command G says POP host is not defined.

Very verbose mutt 1.2 .muttrc example here. I'm using mutt version 1.5.9i though.

Seems like mutt is working ok. But postfix holds my sent messages in /var/spool/postfix/defer with an error message from my ISP mail host: 450 <freddy@linux.site>: Sender address rejected: Domain not found (in reply to RCPT TO command). Solution: when using mail, I have to specify -r from-addr to specify a valid e-mail address to be accepted by my ISP mail host. Now, how do I tell Mutt?

20051117

+-----------+              +----------+
| fetchmail +---------<----+ INTERNET |
+---+-------+              +-----+----+
    |                            |
   -+--------------------        |
   /var/spool/mail/freddy        ^
   ----+-----------------        |
    v                            |
+---+--+                   +-----+---+
| mutt +--------->---------+ postfix |
+---+--+                   +-----+---+
    v                            v
   -+----                     ---+--------------
   ~/Mail (mbox)              /var/spool/postfix
   ------                     ------------------

20051123

It seems that after I manually edit my /etc/postfix/main.cf to change myhostname it is being reset to its old value?

Another useful link: Mail server HOWTO - OpenSUSE

Mail sent by mutt is sent back as 'Undelivered Mail Returned to Sender' to 'freddy@tip.nl'? This is probably from my local machine – not my provider – because I specified myhostname = tip.nl in main.cf and I'm freddy...

This seems to be it: leave myhostname to be my machine, but specify myorigin to be my e-mail provider's domain.

20051126

+-----------+            +-----------+              +----------+
| LOCALHOST |            | fetchmail +---------<----+ INTERNET |
+-----+-----+            +---+-------+              +-----+----+
      |                      |                            |
      |          ------------+---------                   |
      +---->-----/var/spool/mail/freddy                   ^
                 ------------+---------                   |
                             v                            |
                         +---+--+                   +-----+---+
                         | mutt +--------->---------+ postfix |
                         +---+--+                   +-----+---+
                             v                            v
                            -+----                     ---+--------------
                            ~/Mail (mbox)              /var/spool/postfix
                            ------                     ------------------

Why is mail normally stored in one folder? Shouldn't mail be stored per project? Let's take a look if mutt can provide the means. Maybe it's just like normal mail: you immediately get rid of the unwanted mail, archive the important mail and leave some mail for later perusal. Thus, I don't need that many folders for storing mail. With mutt, I can have any project have its own mailbox.

Another useful place for information is the mutt wiki.

20060221

When setting up another server via YaST, I receive this message:

To be able to deliver mail to your local MTA, the value of POSTFIX_LOCALDOMAINS
in /etc/sysconfig/postfix will be set to "\$myhostname, localhost.\$mydomain,
\$mydomain".

20060223

Again (see #20051114), the messages are in /var/spool/postfix/defer with error message: Host or domain name not found. Name service error for name=mail.foo.tv type=MX: Host not found, try again

Got error message from mutt when trying to send mail: ^: Permission denied (errno = 13). Removed ^ from Fcc and folder-hook . 'set record="^"' from muttrc, since the special meaning of ^ is available in mutt-1.5.10 and I'm using 1.5.9.

Google to the rescue: Sending mails to remote domains is not working. - HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials:.
All kinds of useful logs: /var/log/mail.err, /var/log/warn, /var/log/mail.info, /var/log/mail, /var/log/fetchmail. Fetchmail gives error message as well: fetchmail: couldn't find canonical DNS name of foo.nl (foo.nl).
Forum also pointed me to /etc/resolv.conf which is empty indeed on my new system, filled on my old.

The postfix site: Postfix Frequently Asked Questions: Mail stays queued with: Host not found, try again.

Solution: I hadn't setup my DNS. Start YaST, {Network Services | DNS and Hostname}.

Comments

blog comments powered by Disqus